aboutsummaryrefslogtreecommitdiffstats
path: root/xls2csv/xls2csv.spec
diff options
context:
space:
mode:
authormjfernez <mjfernez@gmail.com>2021-03-06 16:41:40 -0500
committermjfernez <mjfernez@gmail.com>2021-03-06 16:41:40 -0500
commit1d832ee6c1c9c6701e6a1ab4c26acdc2dad3784a (patch)
tree3bb8de56c267799a58880071a0f20847231a16ad /xls2csv/xls2csv.spec
parent9ae2789aa268b37716b5296263497c1aa35cf590 (diff)
downloadscripts-n-tools-1d832ee6c1c9c6701e6a1ab4c26acdc2dad3784a.tar.gz
add gitignore
Diffstat (limited to 'xls2csv/xls2csv.spec')
-rw-r--r--xls2csv/xls2csv.spec38
1 files changed, 38 insertions, 0 deletions
diff --git a/xls2csv/xls2csv.spec b/xls2csv/xls2csv.spec
new file mode 100644
index 0000000..2e50693
--- /dev/null
+++ b/xls2csv/xls2csv.spec
@@ -0,0 +1,38 @@
+# -*- mode: python -*-
+
+block_cipher = None
+
+def get_pandas_path():
+ import pandas
+ pandas_path = pandas.__path__[0]
+ return pandas_path
+
+a = Analysis(['XLStoCSV.py'],
+ pathex=['C:\\Users\\Mike\\Desktop\\XLStoCSV'],
+ binaries=[],
+ datas=[],
+ hiddenimports=[],
+ hookspath=[],
+ runtime_hooks=[],
+ excludes=[],
+ win_no_prefer_redirects=False,
+ win_private_assemblies=False,
+ cipher=block_cipher)
+
+dict_tree = Tree(get_pandas_path(), prefix='pandas', excludes=["*.pyc"])
+a.datas += dict_tree
+a.binaries = filter(lambda x: 'pandas' not in x[0], a.binaries)
+
+pyz = PYZ(a.pure, a.zipped_data,
+ cipher=block_cipher)
+exe = EXE(pyz,
+ a.scripts,
+ a.binaries,
+ a.zipfiles,
+ a.datas,
+ name='XLStoCSV',
+ debug=False,
+ strip=None,
+ upx=True,
+ runtime_tmpdir=None,
+ console=True )